re = /^news\/[0-9]+-(.*)/
str = 'news/122-windows-10-the-final-countdown'
subst = 'headlines\\/$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result