$re = '/^news\/[0-9]+-(.*)/';
$str = 'news/122-windows-10-the-final-countdown';
$subst = "headlines\/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;