import re
regex = re.compile(r"^news\/[0-9]+-(.*)")
test_str = "news/122-windows-10-the-final-countdown"
subst = "headlines\\/$1"
result = regex.sub(subst, test_str)
if result:
print(result)