const regex = /^news\/[0-9]+-(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^news\\\/[0-9]+-(.*)', 'g')
const str = `news/122-windows-10-the-final-countdown`;
const subst = `headlines\/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);