# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<\\/p>)\s+<p>[\w ]+<\\/p>//gm;t' <<< " <p>erster Absatz</p>
<p>zweiter Absatz</p>"