use strict;
my $str = ' <p>erster Absatz</p>
<p>zweiter Absatz</p>';
my $regex = qr/(?<=<\/p>)\s+<p>[\w ]+<\/p>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";