const regex = /(?<=<\/p>)\s+<p>[\w ]+<\/p>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<\\\/p>)\\s+<p>[\\w ]+<\\\/p>', 'gm')
const str = ` <p>erster Absatz</p>
<p>zweiter Absatz</p>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);