import Foundation
let pattern = #"(?<=<\/p>)\s+<p>[\w ]+<\/p>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>erster Absatz</p>
<p>zweiter Absatz</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)