re = /(?<=<\/p>)\s+<p>[\w ]+<\/p>/m
str = ' <p>erster Absatz</p>
<p>zweiter Absatz</p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result