#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\b\(\?\:\(\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\]\)\(\?\!\[123456789\]\*\\1\)\)\+\\b"
Local $sString = "\b(?:([1])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([12])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([123])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([1234])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([12345])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([123456])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([1234567])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([12345678])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([123456789])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([11])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([2])(?![123456789]*\1))+\b" & @CRLF & _
"\b(?:([54321])(?![123456789]*\1))+\b"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")