import Foundation
let pattern = #"\\b\(\?\:\(\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\]\)\(\?\!\[123456789\]\*\\1\)\)\+\\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\b(?:([1])(?![123456789]*\1))+\b
\b(?:([12])(?![123456789]*\1))+\b
\b(?:([123])(?![123456789]*\1))+\b
\b(?:([1234])(?![123456789]*\1))+\b
\b(?:([12345])(?![123456789]*\1))+\b
\b(?:([123456])(?![123456789]*\1))+\b
\b(?:([1234567])(?![123456789]*\1))+\b
\b(?:([12345678])(?![123456789]*\1))+\b
\b(?:([123456789])(?![123456789]*\1))+\b
\b(?:([11])(?![123456789]*\1))+\b
\b(?:([2])(?![123456789]*\1))+\b
\b(?:([54321])(?![123456789]*\1))+\b
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)