use strict;
my $str = '\\b(?:([1])(?![123456789]*\\1))+\\b
\\b(?:([12])(?![123456789]*\\1))+\\b
\\b(?:([123])(?![123456789]*\\1))+\\b
\\b(?:([1234])(?![123456789]*\\1))+\\b
\\b(?:([12345])(?![123456789]*\\1))+\\b
\\b(?:([123456])(?![123456789]*\\1))+\\b
\\b(?:([1234567])(?![123456789]*\\1))+\\b
\\b(?:([12345678])(?![123456789]*\\1))+\\b
\\b(?:([123456789])(?![123456789]*\\1))+\\b
\\b(?:([11])(?![123456789]*\\1))+\\b
\\b(?:([2])(?![123456789]*\\1))+\\b
\\b(?:([54321])(?![123456789]*\\1))+\\b';
my $regex = qr/\\b\(\?\:\(\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\]\)\(\?\!\[123456789\]\*\\1\)\)\+\\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}