import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\b\\(\\?\\:\\(\\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\\]\\)\\(\\?\\!\\[123456789\\]\\*\\\\1\\)\\)\\+\\\\b";
final String string = "\\b(?:([1])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([12])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([123])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([1234])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([12345])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([123456])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([1234567])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([12345678])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([123456789])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([11])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([2])(?![123456789]*\\1))+\\b\n"
+ "\\b(?:([54321])(?![123456789]*\\1))+\\b";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}