const regex = /\\b\(\?\:\(\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\]\)\(\?\!\[123456789\]\*\\1\)\)\+\\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\b\\(\\?\\:\\(\\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\\]\\)\\(\\?\\!\\[123456789\\]\\*\\\\1\\)\\)\\+\\\\b', 'gm')
const str = `\\b(?:([1])(?![123456789]*\\1))+\\b
\\b(?:([12])(?![123456789]*\\1))+\\b
\\b(?:([123])(?![123456789]*\\1))+\\b
\\b(?:([1234])(?![123456789]*\\1))+\\b
\\b(?:([12345])(?![123456789]*\\1))+\\b
\\b(?:([123456])(?![123456789]*\\1))+\\b
\\b(?:([1234567])(?![123456789]*\\1))+\\b
\\b(?:([12345678])(?![123456789]*\\1))+\\b
\\b(?:([123456789])(?![123456789]*\\1))+\\b
\\b(?:([11])(?![123456789]*\\1))+\\b
\\b(?:([2])(?![123456789]*\\1))+\\b
\\b(?:([54321])(?![123456789]*\\1))+\\b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}