using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\b\(\?\:\(\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\]\)\(\?\!\[123456789\]\*\\1\)\)\+\\b";
string input = @"\b(?:([1])(?![123456789]*\1))+\b
\b(?:([12])(?![123456789]*\1))+\b
\b(?:([123])(?![123456789]*\1))+\b
\b(?:([1234])(?![123456789]*\1))+\b
\b(?:([12345])(?![123456789]*\1))+\b
\b(?:([123456])(?![123456789]*\1))+\b
\b(?:([1234567])(?![123456789]*\1))+\b
\b(?:([12345678])(?![123456789]*\1))+\b
\b(?:([123456789])(?![123456789]*\1))+\b
\b(?:([11])(?![123456789]*\1))+\b
\b(?:([2])(?![123456789]*\1))+\b
\b(?:([54321])(?![123456789]*\1))+\b";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}