$re = '/\\\\b\(\?\:\(\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\]\)\(\?\!\[123456789\]\*\\\\1\)\)\+\\\\b/m';
$str = '\\b(?:([1])(?![123456789]*\\1))+\\b
\\b(?:([12])(?![123456789]*\\1))+\\b
\\b(?:([123])(?![123456789]*\\1))+\\b
\\b(?:([1234])(?![123456789]*\\1))+\\b
\\b(?:([12345])(?![123456789]*\\1))+\\b
\\b(?:([123456])(?![123456789]*\\1))+\\b
\\b(?:([1234567])(?![123456789]*\\1))+\\b
\\b(?:([12345678])(?![123456789]*\\1))+\\b
\\b(?:([123456789])(?![123456789]*\\1))+\\b
\\b(?:([11])(?![123456789]*\\1))+\\b
\\b(?:([2])(?![123456789]*\\1))+\\b
\\b(?:([54321])(?![123456789]*\\1))+\\b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);