# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\\b\(\?\:\(\[(1|12|123|1234|12345|123456|1234567|12345678|123456789)\]\)\(\?\!\[123456789\]\*\\1\)\)\+\\b"
test_str = ("\\b(?:([1])(?![123456789]*\\1))+\\b\n"
"\\b(?:([12])(?![123456789]*\\1))+\\b\n"
"\\b(?:([123])(?![123456789]*\\1))+\\b\n"
"\\b(?:([1234])(?![123456789]*\\1))+\\b\n"
"\\b(?:([12345])(?![123456789]*\\1))+\\b\n"
"\\b(?:([123456])(?![123456789]*\\1))+\\b\n"
"\\b(?:([1234567])(?![123456789]*\\1))+\\b\n"
"\\b(?:([12345678])(?![123456789]*\\1))+\\b\n"
"\\b(?:([123456789])(?![123456789]*\\1))+\\b\n"
"\\b(?:([11])(?![123456789]*\\1))+\\b\n"
"\\b(?:([2])(?![123456789]*\\1))+\\b\n"
"\\b(?:([54321])(?![123456789]*\\1))+\\b")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.