using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe[\S\s]*?src="".*?\.(\w+)\..*?""";
string input = @"<iframe id=""ytplayer"" type=""text/html"" width=""640"" height=""360""
src=""http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com""
frameborder=""0""/>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}