$re = '/<iframe[\S\s]*?src=".*?\.(\w+)\..*?"/';
$str = '<iframe id="ytplayer" type="text/html" width="640" height="360"
src="http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com"
frameborder="0"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);