// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<iframe[\S\s]*?src=".*?\.(\w+)\..*?""#).unwrap();
let string = "<iframe id=\"ytplayer\" type=\"text/html\" width=\"640\" height=\"360\"
src=\"http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com\"
frameborder=\"0\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}