package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<iframe[\S\s]*?src=".*?\.(\w+)\..*?"`)
var str = `<iframe id="ytplayer" type="text/html" width="640" height="360"
src="http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com"
frameborder="0"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}