re = /<iframe[\S\s]*?src=".*?\.(\w+)\..*?"/
str = '<iframe id="ytplayer" type="text/html" width="640" height="360"
src="http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com"
frameborder="0"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end