#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<tr class="class1">)([\s\S]*?)(<\/tr>)"
Local $sString = "<tr class="class1">" & @CRLF & _
" <td class="class2">" & @CRLF & _
" <a href="some_address"></a>" & @CRLF & _
" <div id="id1">" & @CRLF & _
" <span class="class3"></span>" & @CRLF & _
" </div>" & @CRLF & _
" <span>Just a text</span>" & @CRLF & _
" </td>" & @CRLF & _
"</tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")