using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<tr class=""class1"">)([\s\S]*?)(<\/tr>)";
string input = @"<tr class=""class1"">
<td class=""class2"">
<a href=""some_address""></a>
<div id=""id1"">
<span class=""class3""></span>
</div>
<span>Just a text</span>
</td>
</tr>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}