package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<tr class="class1">)([\s\S]*?)(<\/tr>)`)
var str = `<tr class="class1">
<td class="class2">
<a href="some_address"></a>
<div id="id1">
<span class="class3"></span>
</div>
<span>Just a text</span>
</td>
</tr>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}