using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"NAME=""var1"".+?VALUE=""(.+?)""";
string input = @"<INPUT TYPE=""HIDDEN"" NAME=""var1"" VALUE=""value that i want to be captured""/><INPUT TYPE=""HIDDEN"" NAME=""var2"" VALUE=""value2""/><INPUT TYPE=""SUBMIT"" VALUE=""value that is captured, but i don't want to be captured"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}