import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "NAME=\"var1\".+?VALUE=\"(.+?)\"";
final String string = "<INPUT TYPE=\"HIDDEN\" NAME=\"var1\" VALUE=\"value that i want to be captured\"/><INPUT TYPE=\"HIDDEN\" NAME=\"var2\" VALUE=\"value2\"/><INPUT TYPE=\"SUBMIT\" VALUE=\"value that is captured, but i don't want to be captured\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}