import re
regex = re.compile(r"NAME=\"var1\".+?VALUE=\"(.+?)\"", flags=re.MULTILINE)
test_str = "<INPUT TYPE=\"HIDDEN\" NAME=\"var1\" VALUE=\"value that i want to be captured\"/><INPUT TYPE=\"HIDDEN\" NAME=\"var2\" VALUE=\"value2\"/><INPUT TYPE=\"SUBMIT\" VALUE=\"value that is captured, but i don't want to be captured\" />"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")