$re = '/NAME="var1".+?VALUE="(.+?)"/m';
$str = '<INPUT TYPE="HIDDEN" NAME="var1" VALUE="value that i want to be captured"/><INPUT TYPE="HIDDEN" NAME="var2" VALUE="value2"/><INPUT TYPE="SUBMIT" VALUE="value that is captured, but i don\'t want to be captured" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);