re = /NAME="var1".+?VALUE="(.+?)"/m
str = '<INPUT TYPE="HIDDEN" NAME="var1" VALUE="value that i want to be captured"/><INPUT TYPE="HIDDEN" NAME="var2" VALUE="value2"/><INPUT TYPE="SUBMIT" VALUE="value that is captured, but i don\'t want to be captured" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end