# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^.*)[^a-zA-Z\s](?=.{5})/x/g;t' <<< "4567 6365 7987 3783
3457 732837 82372"