use strict;
my $str = '4567 6365 7987 3783
3457 732837 82372';
my $regex = qr/(?!^.*)[^a-zA-Z\s](?=.{5})/p;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";