import Foundation
let pattern = #"(?!^.*)[^a-zA-Z\s](?=.{5})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
4567 6365 7987 3783
3457 732837 82372
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)