const regex = /(?!^.*)[^a-zA-Z\s](?=.{5})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^.*)[^a-zA-Z\\s](?=.{5})', 'g')
const str = `4567 6365 7987 3783
3457 732837 82372`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);