re = /(?!^.*)[^a-zA-Z\s](?=.{5})/
str = '4567 6365 7987 3783
3457 732837 82372'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result