using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^.*)[^a-zA-Z\s](?=.{5})";
string substitution = @"x";
string input = @"4567 6365 7987 3783
3457 732837 82372";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}