#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bhref="(?:[^"]*)topic\/(\d+)-.*">$"
Local $sString = "href="http://google.com/topic/713725-dogs-are-great-3">" & @CRLF & _
"href="http://google.com/topic/213225-humans-are-great">" & @CRLF & _
"href="http://google.com/topic/342315-cats-are-great-but-small">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")