// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bhref="(?:[^"]*)topic\/(\d+)-.*">$"#).unwrap();
let string = "href=\"http://google.com/topic/713725-dogs-are-great-3\">
href=\"http://google.com/topic/213225-humans-are-great\">
href=\"http://google.com/topic/342315-cats-are-great-but-small\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}