using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhref=""(?:[^""]*)topic\/(\d+)-.*"">$";
string input = @"href=""http://google.com/topic/713725-dogs-are-great-3"">
href=""http://google.com/topic/213225-humans-are-great"">
href=""http://google.com/topic/342315-cats-are-great-but-small"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}