import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhref=\"(?:[^\"]*)topic\\/(\\d+)-.*\">$";
final String string = "href=\"http://google.com/topic/713725-dogs-are-great-3\">\n"
+ "href=\"http://google.com/topic/213225-humans-are-great\">\n"
+ "href=\"http://google.com/topic/342315-cats-are-great-but-small\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}