use strict;
my $str = 'href="http://google.com/topic/713725-dogs-are-great-3">
href="http://google.com/topic/213225-humans-are-great">
href="http://google.com/topic/342315-cats-are-great-but-small">';
my $regex = qr/\bhref="(?:[^"]*)topic\/(\d+)-.*">$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}