const regex = /\bhref="(?:[^"]*)topic\/(\d+)-.*">$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhref="(?:[^"]*)topic\\\/(\\d+)-.*">$', 'gm')
const str = `href="http://google.com/topic/713725-dogs-are-great-3">
href="http://google.com/topic/213225-humans-are-great">
href="http://google.com/topic/342315-cats-are-great-but-small">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}