# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n(?=\w+ \d)/\n--------------------\n/g;t' <<< "Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno"