using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n(?=\w+ \d)";
string substitution = @"\n--------------------\n";
string input = @"Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}