import Foundation
let pattern = #"\n(?=\w+ \d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n--------------------\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)