$re = '/\n(?=\w+ \d)/';
$str = 'Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno';
$subst = "\n--------------------\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;