import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n(?=\\w+ \\d)";
final String string = "Abc 123 def\n"
+ "ghi\n"
+ "jkl\n"
+ "Abc 123 def ghi jkl mno\n"
+ "Abc 123 def ghi jkl \n"
+ "mno";
final String subst = "\\n--------------------\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}