const regex = /\n(?=\w+ \d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n(?=\\w+ \\d)', 'g')
const str = `Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno`;
const subst = `\n--------------------\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);