use strict;
my $str = 'Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno';
my $regex = qr/\n(?=\w+ \d)/p;
my $subst = '\\n--------------------\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";