#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\n(?=\w+ \d)"
Local $sString = "Abc 123 def" & @CRLF & _
"ghi" & @CRLF & _
"jkl" & @CRLF & _
"Abc 123 def ghi jkl mno" & @CRLF & _
"Abc 123 def ghi jkl " & @CRLF & _
"mno"
Local $sSubst = "\n--------------------\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)